
Altering the 3D extrude
Pressing the 'E' button (or ALT+E on the keyboard) displays the Extrude dialog box. This lets you change the 
extrude 3D depth, and whether the text is shown glossy or matt. 
You can also change the text color - see Altering the text color for details.
You have the choice of omitting the front or back face of the text. This can create some interesting effects. 
See also
Altering the lights
Altering the background
Altering the Bevel
Altering the font
Altering the text
Altering the text color
Using a texture to color the text



Altering the Bevel
You can adjust the bevel - that is the type of corner that is applied to the edge of the text - by typing ALT+B or 
pressing the ‘B’ button to display the bevel dialog box.
You can select various bevel types from the list, and the size of the bevel by typing in the bevel depth. Note that the
bevel size is relative to the extrude depth, so that the greater the 3D depth of the text, the more obvious the bevel 
is. Also note that the bevels go along the side of the text, not the face of the text. So, for example, selecting the 
'Curved' bevel produces a budge effect to the extruded part.
Notes
Beveled text is slower to display than text with no bevel.
The Miter and Round options affect the corners of the lettering. Usually it's displayed with a sharp mitered corners, 
but you can round this off by selecting the Round options. This is usually only obvious for fonts that have sharp 
corners or serifs.
See also
Altering the font
Altering the text
Altering the text color
Using a texture to color the text
Altering the 3D extrude
Altering the lights
Altering the background



Altering the background color or texture
To use a flat color as the background behind the text choose Background Color from the View menu. This 

displays the Color Picker.
To use a bitmap texture as the background choose Background Texture from the View menu. You can also 

drag-and-drop textures onto the background.
Bitmap texture backgrounds are useful where you want a 3D text heading to appear on a web page that 

has a texture background.    Using the same bitmap as the web page background ensures that any 3D heading 'fits 
in' with the whole page background. You can import any BMP, PNG, JPEG or GIF file as a background and Xara3D 
repeats this (tiles it) in exactly the same way as a Web browser.

Note that the actual bitmap is not stored inside the X3D file. If you give someone a Xara3D file that uses a 
texture, also give them the bitmap file. For transferring files to other people, we suggest storing the bitmap file 
in the same folder as the X3D file. Xara3D automatically finds bitmap files in the same folder.

See also
Altering the font
Altering the text
Altering the 3D extrude
Altering the text color
Using a texture to color the text
Altering the lights
Altering the Bevel



Altering the font
Use the dropdown list on the Text Toolbar (at the bottom of the window) to alter the font. Any installed TrueType font
is available in the font list. With Xara3D you may find that some of the more unusual block and ‘curvy’ fonts work 
particularly well.
Click B (or press CTRL+B) to make the text bold.
Click I (or press CTRL+I) to make the text italic..
Note:
You can also click the "T" button at the top of the window to display the Text options dialog box. This lets you 
preview the different fonts installed on your computer. Use the up/down cursor (arrow) keys on the keyboard to step
up and down the list of fonts.
See also
Altering the text
Altering the 3D extrude
Altering the Bevel
Altering the lights
Altering the text color
Using a texture to color the text
Altering the background color or texture



Altering the lights
Xara3D has three lights shining on the text. These lights can be any position and color you wish. 
To view the lights:

1. Press the ‘light bulb’ button. (You can also press CTRL+TAB.) 
This shows the three lights, represented by colored arrows that are initially red, green and blue. You can alter the 
color of any light by double clicking the appropriate light arrow. To learn how to select colors see The Color Picker
To reposition a light:

1. Simply drag on it. This rotates the light around the text object. 
To make the light go behind the text, just keep dragging right or left until it rotates behind the object.
Note:
An alternative way to control the light colors is right-click on the window. This brings up a pop-up menu that allows 
you to control all three lights as well as colors or bitmap textures.
See also
Altering the font
Altering the text
Altering the text color
Using a texture to color the text
Altering the 3D extrude
Altering the Bevel
Altering the background



Altering the text
Maximum number of characters: 80
You can either directly edit the text in the window or use the Text Options dialog box. Text Options is easier to use 
when editing complex text that is slow to redraw on screen. Click the 'T' button to open the Text Options dialog box 
(or press ALT+T.)
On-screen editing:
    To add characters to the end of the text: type the characters as normal.
    To start a new line: press Enter.
    To delete characters from the end of the text: press the BACKSPACE key on the keyboard.
    To edit text:

1. Click the Show/Hide Cursor button (the I-beam) to select it. This displays a vertical cursor.
2.Using the arrow keys on the keyboard to move the cursor.
3.You can then type in new text or delete existing text using BACKSPACE or DELETE.

Text Toolbar:
To change the spacing between characters: change Tracking on the Text Toolbar (displayed at the 

bottom of the window.) Tracking is measured in ems. One em is the width of the letter 'M' in the current font. 
To make the text wider or narrower: change Aspect Ratio on the Text Toolbar (displayed at the bottom 

of the window.) 100% is regular width. Less than 100% compresses the characters. Note the difference between 
Aspect Ratio (change the width of characters) and Tracking (change the width between characters.)

To change spacing between lines of text: change Line Spacing on the Text Toolbar (displayed at the 
bottom of the window.) This value is a percentage of the regular line spacing. 100% is regular spacing. Less than 
100% moves the lines closer together. Line spacing has no effect for a single line of text.

To change the alignment of two or more lines of text: click the three align buttons on the Text 
Toolbar. These buttons have no effect for a single line of text.
See also:
Altering the font
Altering the text color
Using a texture to color the text
Altering the 3D extrude
Altering the Bevel
Altering the background
Altering the lights



Altering the text color or texture
Normally the text is white, and colored by the three lights shining upon it. 
Changing the text color:
However you can change the color of the text by choosing Text Color on the View menu. This displays the Color 
Picker. If you select anything but a very light or pale color you'll find the light colors have relatively little effect.
Using a texture to color the text:
You can also use a bitmap texture to color the text. Use Text Texture on the View menu to select a bitmap. You can 
use any BMP, PNG, JPEG or GIF file. For light colored textures you can use the normal lighting. Darker textures need 
bright lights (white or pale colors) to give the best results. You can also drag-and-drop textures onto the text.
Note that the actual bitmap is not stored inside the X3D file. If you give someone a Xara3D file that uses a texture, 
also give them the bitmap file. For transferring files to other people, we suggest storing the bitmap file in the same 
folder as the X3D file. Xara3D automatically finds bitmap files in the same folder.
Shiny or matt text surface
The surface of the text can be shiny or matt - this alters the reflectivity of the surface. The Extrude dialog box 
controls this. Press the 'E' button (or ALT+E on the keyboard) to display this dialog box.
However the difference won't always be obvious unless the lights are at the necessary angle to reflect off the 
surface. This is usually obtained by arranging the lights to be behind the text (keep dragging the light right or left so
it goes behind) so it can reflect off the surface of the text.



Changing the shortcut
Installing Xara3D places a shortcut to the program in the top level of the Programs menu. 
To move the shortcut to a submenu:

1. Right click on the Start menu on the Taskbar and select Open. 
2. Double-click on Programs. This displays the contents of the top level menu with Xara3D shown at the 

bottom. 
3. To move Xara3D to another folder simply drag and drop it over the desired folder.

To create a shortcut on the Windows backdrop:
Drag the icon to the Windows background. This gives you easy access to the program right from the desktop.



Help for Xara3D
Welcome to Xara3D, a ‘slimware’ program that produces great, super high quality, three-dimensional text headings,
and animated GIFs in seconds. 
The online Help provided here is deliberately simple and lacking illustrations in order to keep the download size 
small. A more descriptive, illustrated version of the documentation is available online at 
http://www.xara.com/xara3D/helpv2/

Introduction
Installing the free fonts
Moving the Xara3D short-cut
Purchasing Xara3D
Unlock codes and Key codes
What's New in Version 2

The basics
Positioning, rotating and sizing
Altering the text
Altering the font
Altering the text color
Using a texture to color the text
Altering the 3D extrude
Altering the bevel
Altering the lights
Altering the background
Saving a 3D image
Creating a movie or animated GIF
Correcting mistakes

The Color Picker
Previewing AVI movies
Customizing Xara3D
Direct3D
Keyboard short cuts
Hidden or advanced operations
Uninstalling Xara3D
Technical support

Version 2.0 March 1998
All trademarks acknowledged

The license distributed with Xara3D grants you the right to use the Xara3D software on a single client computer at a
time and by a single user at a time, subject to the restrictions listed below and the disclaimer relating to warranties,
support and damages.
1. Disclaimer: This software is provided on an "as is" basis, without any other warranties, or conditions, express or 
implied, including but not limited to warranties of merchantable quality, merchantability or fitness for a particular 
purpose, or those arising by law, statute, usage of trade or course of dealing. The entire risk as to the results and 
performance of the Product is assumed by you. Neither we nor our dealers or suppliers shall have any liability to 
you or any other person or entity for any indirect, incidental, special or consequential damages whatsoever, 
including but not limited to loss of revenue or profit, lost or damaged data or other commercial or economic loss, 
even if we have been advised of the possibility of such damages or they are foreseeable; or for claims by a third 
party. You may have other rights which vary from state to state. 
2. Restrictions: This license gives you the right to use this software but all rights not specifically mentioned in this 
agreement, including ownership rights, intellectual property rights, trademarks and copyright, are reserved by Xara 
Ltd. You may not decompile, reverse engineer, disassemble or otherwise reduce the software to a human 
perceivable form. You may not modify, rent or resell for profit the software, or create derivative works based upon 
the software. 



Correcting mistakes
You often need to experiment to get the best results. Xara3D makes this easy - if you don't like the result use Undo 
button to discard the change. Also on the Edit menu or press CTRL+Z.) It's not just the last operation you can undo. 
Xara3D has unlimited undo so you can step all the way back to the beginning.
If you step back too far, click the Redo button (also on the Edit menu or CTRL+Y) to undo an Undo. You can use 
Redo at any time until you make new changes.



Creating a movie or Animated GIF
It's incredibly easy to create rotating text animations and movies in Xara3D. You can preview a rotating animation 
by pressing the rotate button. The text can rotate either horizontally or vertically around its center. You can control 
the rotation speed and frame rate using the animation dialog box available from the A button.
Rather than always doing a complete 360 degree revolution, where you would see the back side of the text which is
difficult to read, Xara3D includes an option to show only the front face of the text. This restricts the rotation to 180 
degrees so that, although it appears to perform a continuous rotation, it actually skips 180 degrees and the text is 
always readable.    This has another significant advantage of reducing the file size of the animation, particularly 
important for Animated GIFs.
Steps to producing a movie or animation:

1.Resize the Xara3D window to the required image size. Remember that Animated GIFs need be very small to 
have an acceptable download time.

2.Select the Animation dialog box (the A button) and choose the number of frames per revolution. Again for 
Animated GIFs the fewer the better. 

3.Choose the number of frames per second (animation speed). A slow animation speed with only a few frames 
per revolution can give a jerky animation - you may need to experiment to get the best results.

4.Select Export Animation on the File menu, and select AVI or Animated GIF file type, and give the file a name and
press Save. This displays the Export quality dialog box where you can select the quality number and number of 
colors etc., see Export options for AVI movies and Export options for Animated GIFs

When previewing an animation, the program displays a much lower quality to be as fast as possible - however when
exporting an Animated GIF or AVI movie Xara3D always renders all frames at the maximum quality. To preview an 
Animated GIF simply drop the file onto your web browser window. 
Xara3D can produce, in minutes, top quality Animated GIFs and movies that would take hours using traditional 3D 
design programs.
See also
Previewing AVI movies
Tips for reducing the size of Animated GIFs



Customizing Xara3D
Displaying Toolbars
The View menu lets you control display of:

the main Toolbar at the top of the window
the Text Toolbar at the bottom of the window
the Status Bar, also at the bottom of the window

Docking dialog boxes
The Extrude, Bevel and Animate options dialog boxes can be either free-floating (you can move them independently
of the main window) or docked (attached to the side of the window.)
To dock a dialog box:

1.Drag the dialog box over either the left hand edge or right hand edge of the window. The dialog box outline 
changes to a thin line when it can be docked.

To undock a dialog box:
1.Drag the dialog box away from the window. The outlines changes to a thick line when undocked.



Direct3D
Xara3D doesn't use Direct3D as the Xara3D engine is more advanced in many ways than the Microsoft Direct3D 
software solution (for example, the anti-aliasing). Obviously having a hardware accelerator would be faster; 
however these are also usually inferior quality (again no anti-aliasing). Future versions of Xara3D may offer a 
Direct3D option as and when hardware accelerators are able to render the same quality as Xara3D.



Export options for AVI movies
Experimentation has shown that exporting AVIs as 24-bit produces the smallest file size. Perhaps surprisingly, 
exporting as 256 color (8-bit) produces larger files but usually higher quality. This is because it uses a different 
compression system.
Current Window Size lets you export just area surrounding the text (Crop on) or the entire window area (Crop off.) 
User Defined lets you specify the dimensions of the bitmap. With Fit to Width (on the Text Toolbar) selected, the text
and the background scales to suit the values you type in. If you specified a font size, the size of the text does not 
change but the background scales to the values you type in. This is useful if you want to create several headings, 
all the same height and width.
Note. It’s very important to make sure the compression option is switched on. Even at 100% quality, compression 
makes the file up to 10 times smaller.
See also
Creating a movie or Animated GIF
Previewing AVI movies



Export options for Animated GIFs
To learn more about exporting animated GIFs see Creating a movie or Animated GIF
Because Animated GIFs can be quite large, you may find that a 4-bit, optimized palette per frame, produces the 
best results for the smallest file size. However experimentation is recommended.
Dithering always makes GIFs look better, but at the same time makes them larger. When outputting at 256 colors 
you may find that there is no need to turn dithering on.
Current Window Size lets you export just area surrounding the text (Crop on) or the entire window area (Crop off.) 
User Defined lets you specify the dimensions of the bitmap. With Fit to Width (on the Text Toolbar) selected, the text
and the background scales to suit the values you type in. If you specified a font size, the size of the text does not 
change but the background scales to the values you type in. This is useful if you want to create several headings, 
all the same height and width.
Note:
There is an issue with ‘optimized palette per frame’ with Macintosh web browsers. Unfortunately they all seem to 
have a serious bug that prevents per frame optimization working. If you know your audience consists of Mac 
viewers then we advise you not to use per frame palette optimization.
See also
Tips for reducing the size of Animated GIF files



Export options for GIF, PNG or BMP
GIF export is the most common and probably the best format for use on the Web. GIF images can have no more 
than 256 colors, which you might think is a limitation. However, using Xara3D’s advanced dithering and palette 
optimization features, you can get near perfect quality images using only 256 colors. Indeed you’ll be surprised at 
how good GIFs with just 16 colors can be.
For all export formats you have control over not only the number of colors but also whether the image is dithered 
and has an optimized palette. These are techniques to improve the image quality while using a reduced number of 
colors. For example using only 16 color GIF nearly always produces the smallest file size, but with no dithering the 
shading can be poor. By using an optimized palette and diffusion dithering you can substantially increase the 
quality of the result.    
There are no hard and fast rules as to which combination of export options is best - it depends on the image and 
your requirements. Therefore we recommend exporting in a number of different formats to see which is the best 
and has the smallest file size. Typical options to try include 16 color with diffusion dithering, or 256 color with no 
dithering.
For examples of the different quality settings see the web page GIF quality settings
When exporting as a GIF or PNG you have the option of making it interlaced    (progressive rendering as it’s 
downloaded) and whether the image is transparent.    For more details on the transparent options see the web page 
GIF & PNG transparency
Current Window Size lets you export just area surrounding the text (Crop on) or the entire window area (Crop off.) 
User Defined lets you specify the dimensions of the bitmap. With Fit to Width (on the Text Toolbar) selected, the text
and the background scales to suit the values you type in. If you specified a font size, the size of the text does not 
change but the background scales to the values you type in. This is useful if you want to create several headings, 
all the same height and width.
Additional quality control:
Also available from Xara is Xara Webster, which provides even more advanced color reduction facilities and can be 
used to further reduce the size of files by selecting intermediate numbers of colors. To do this, export the image as 
a True color 24-bit BMP image and use Xara Webster to color reduce the file to a specific number of colors.
More details on Xara Webster



Export options for JPG
JPEG bitmaps are always 24-bit, true color, but the JPEG compression system means that the quality is often not as 
good as a GIF.    The Quality setting determines how small the resultant file is - the higher the quality, the larger the 
file. Quality settings less than 80% usually produce inferior images to those available from using palette optimized 
GIFs.
Current Window Size lets you export just area surrounding the text (Crop on) or the entire window area (Crop off.) 
User Defined lets you specify the dimensions of the bitmap. With Fit to Width (on the Text Toolbar) selected, the text
and the background scales to suit the values you type in. If you specified a font size, the size of the text does not 
change but the background scales to the values you type in. This is useful if you want to create several headings, 
all the same height and width.



Hidden or advanced options
Wire-frame mode:
You can turn on a wire-frame mode that can speed up the moving and positioning. To do this press CTRL+SHIFT+W 
Press it again to turn wire-frame off.
Perspective:
You can adjust the Z distance of the object using CTRL and + or    - keys on the numeric keypad. Note that at 
maximum zoom you get a rather unrealistic perspective, as if the image were very close to the eye, causing a fish-
eye lens effect. This exaggerates the perspective. The default perspective is about right for the typical distance 
these images will be viewed on screen.



Installing the fonts
After you have run the installer, three free fonts are included in a Font folder. You can preview the fonts simply by 
double clicking on them in this folder. To use these fonts in Xara3D or other Windows programs, you need to install 
them using the Fonts Control Panel. 
To install the fonts:

1. Open the Control Panel by double-clicking on Control Panel in My Computer. 
2. Open the Fonts Control Panel by double clicking on its name.    This shows all the TrueType fonts installed on 

your system.
3. Drag the fonts over the Fonts Control Panel window. 

Notes:
In step (1) you can also click Start on the Taskbar then choose Settings, Control Panel.
In step (3) you can also select the menu    Install New Font on the File menu of the Font Control Panel, and 

then locate the fonts on your hard disc where Xara3D was installed.
The three free fonts are called:

Balthazar - an unusual old fashioned ‘pen’ font
Dayton - a modern blocky font
GeoType - a wonderful collection of symbols and shapes. Kindly provided by Gary David Bouton.

The first two fonts are from the large Xara collection of fonts available for individual download at 
http://www.xara.com/resources/fonts/



Introduction
Xara3D is a ‘slimware’ program as opposed to the increasingly complex 'bloatware' that is released from the major 
software developers nowadays. This does not mean that Xara3D is low quality or produces inferior results compared
to more complex 3D programs; on the contrary, it produces better output, and faster than just about anything else.
'Bloatware', while often very capable, includes so many features that most people never get to use more than 10% 
of the functionality. It's often huge, impractical to download over the Internet, requires huge amounts of disc space, 
and is nearly always so complex that to use its advanced features takes a considerable learning effort.
Xara3D is designed to be a program that does one thing, and does it supremely well, that is dead simple to use, and
costs very little. It's designed to be small enough to be easily downloaded from the Internet.
Xara3D produces high quality three-dimensional text images and nothing else. These images would typically be 
used on Web pages although they can be used anywhere. Xara3D can create animated rotating 3D images with 
absolute ease (AVI movie or GIF). You have control over the text, the font, the depth of the 3D extrude, the type of 
the bevel on the text and the lighting. You can position and rotate the text just by dragging, and it updates the 
image in real-time, interactively. You resize the image just by resizing the window. It couldn't be easier.
See also
Installing the free fonts



Keyboard short cuts
Open new document CTRL+N
Open existing document CTRL+O
Save document CTRL+S
Export image CTRL+SHIFT+E
Export animation CTRL+SHIFT+X
Undo last operation CTRL+Z
Redo (cancel Undo) CTRL+Y
Open Animation Options ALT+A
Open Bevel Options ALT+B
Open Extrude Options ALT+E
Display text bar CTRL+T
Display text cursor CTRL+E
Display lights CTRL+TAB
Start/stop animation CTRL+SPACE
Cancel rotation ALT+HOME
1 degree rotation ALT+arrow keys
15 degree rotation CTRL+ALT+arrow keys
Change color of text ALT+C
Apply texture to text CTRL+SHIFT+C
Change color of background ALT+E
Apply texture to background CTRL+SHIFT+E
Edit light 1 color ALT+1
Edit light 2 color ALT+2
Edit light 3 color ALT+3
Make text bold CTRL+B
Make text italic CTRL+I
Make character to right of cursor upper case

CTRL+U
Make character to right of cursor lower case

CTRL+SHIFT+U
Swap case of character to right of cursor

CTRL+W
Display text cursor CTRL+E
Display as wireframe CTRL+SHIFT+W
Copy text to clipboard CTRL+C
Paste clipboard contents CTRL+V



Position, rotation and sizing
To position or rotate the text :

1.Drag on the window. The operation of this has been designed to be as intuitive as possible. 
Hold down CTRL to move only horizontally.
Hold down SHIFT to move only vertically.

Alternatively you can use the vertical and horizontal scroll bars to rotate the object vertically or horizontally.
If you want a precise rotation, hold down ALT and use the cursor (arrow) keys on the keyboard to change the 
rotation in 1 degree steps. SHIFT+ALT+ the cursor keys gives 15 degree steps.
To control the size of the text:
You can control the size of the text in two ways:

resizing the Xara3D window by dragging the bottom right corner, as you would normal windows
or specifying a size for the text in points. Change the text size using the Text Size field on the Text toolbar. 

Either type in a new value or select one from the drop down list.
To switch between the sizing options:

1.If the Text toolbar is not displayed at the bottom of the window choose Text Toolbar on the View menu.
2.In Font Size select Fit to Width to resize the text as you resize the window. Alternatively specify the text size in 

points.
Everything in Xara3D is WYSIWYG - so with either method, the size you see in the window will be the size of the 
resultant image on your Web page. (Although you can override the size setting when you export the image.)
Xara3D uses one of the most advanced 3D rendering engines around. For instance, it automatically anti-aliases the 
image to produce the highest quality jaggy-free image. However as the anti-aliasing process can take a second or 
two, when you are ‘interacting’ with Xara3D (that is when you are dragging the text or altering other aspects in real
time, such as the lighting) the program produces a lower-quality non anti-aliased display. When you stop moving or 
altering things, the program automatically redisplays the top quality version.



Previewing AVI movies
To preview a movie:

1. Double-click on the movie file icon.
However this uses the standard Windows 95 AVI player which plays the movie once and then closes the window. If 
you want to keep the movie on screen, right-click on the AVI file icon and select Open. When the movie player has 
opened, you can select the 'Auto-repeat' option that allows the AVI movie to cycle continuously.
Microsoft have recently made available a newer and more advanced movie playing solution, called ActiveMovie. 
This is available for free download on the Web. See http://www.microsoft.com/ie/download/
You will need to select the OS type (Windows 95 and NT4) and then proceed to select ActiveMovie 1.0 for Windows 
95 and NT4.



Previewing GIF and JPEG files
The easiest way to see how your saved GIF or JPEG files will appear on the web is to preview using your web 
browser.
To preview GIF and JPEG files:

1. Drag the file from the folder in which you saved the file and drop it over your web browser window. This works 
for both Netscape and Microsoft Internet Explorer. The same applies to animated GIFs.

Note that Netscape versions prior to Navigator 4 do not get the timing right for animated GIFs - they always ran 
about half the speed they should. Navigator version 4 and Internet Explorer display animation with the correct inter-
frame timing.
See also
Previewing AVI movies



Unlocking Xara3D
Purchasing over the Web uses two keys:

a nine letter Key code
a seven letter Unlock code

The Key code changes if you change or reformat your hard drive or change to a new computer. You will
need a new Unlock code.
If you have already purchased Xara3D, you will not be charged for getting a new Unlock code. However, you will 
need your XaraClub user name and password. Forgotten your password? The XaraClub FAQ pages 
(http://www.club.xara.com/clubxarafaq.asp) tells you how to get the password hint you typed in when you joined 
XaraClub.
To unlock Xara3D:

1. If necessary, reinstall Xara3D.
2. Run Xara3D and click Purchase.
3. The Title Bar of the dialog box shows you the nine letter Key code. Make a note of this code.
4. Click Purchase Online or type in the URL https://secure.commerce.xara.com/x3d/unlockmain.asp
5. Follow the instructions for generating a new unlock code.
6. Type that seven letter Unlock code into the Purchase dialog box in Xara3D. Note: use upper case letters - type 

'ABCDEFG' not 'abcdefg'.
Remember: this Unlock code applies only to your current set-up. Changing the hard disc or computer means you 
need a new Unlock code.
Related Topic:
Purchasing Xara3D



Purchasing Xara3D
This page applies if you are running the time-limited trial version of Xara3D.
This version of the software displays a background message, which you cannot change. (With the full version you 
can use any color or bitmap as a background.)
When you start up Xara3D a dialog box reminds you that you are running the trial version - click Purchase on that 
dialog box. This lets you purchase Xara3D using a fully secure transaction process.
If you have already purchased Xara3D but get an 'Invalid Key Code' message or need a new Unlock 
Code:
look at the Unlock Codes page for more details.



Saving an image
When you've positioned and sized the image as required you will need to export the image in one of the appropriate
bitmap formats. Xara3D can export the image as: BMP, PNG, GIF or JPEG static bitmap images, or either of two 
animating types - AVI movie and Animated GIF. 
To save an image:

1. For static bitmaps choose Export Bitmap on the File menu.
For animations choose Export Animation on the File menu.
(Or click the Export button on the Toolbar. This exports an animation if the image is rotating otherwise a static 
image.)

2. Select the appropriate type from the drop down "Save as type" list on the export dialog box
3. Enter the required name.
4. Press OK. This displays the export options dialog box which provides all the control over the quality of image.    

Depending on which bitmap export type you’ve chosen you’ll get a number of different export options as follows
    Export options for GIF, PNG, or BMP

Export options for Animated GIF
Export options for JPG
Export options for AVI movies

Hint
While there are no hard and fast rules as to which file type, JPEG or GIF, is best for the web, we suggest trying GIF 
format first as this can produce higher quality images than JPEG. 
See also
Previewing GIF and JPEG files



Technical support
If you have any problems with Xara3D you can contact our tech support by emailing technical@xara.com
or alternatively you can send feedback directly from our web site http://www.xara.com/feedback/index.html



The Color Picker
The Color Picker lets you select any hue and any shade of color. 
To adjust the shade:

1. Click or drag on the central area of the Color Picker. You'll see the exact color in the top right corner of the 
dialog box. 

To alter the hue:
1. Click or drag on the rainbow strip along the lower part of the dialog box.

HSV and RGB
If you want a exact color type in values:

HSV (Hue, Saturation, Value) Hue is a color wheel with values in the range 0-360 degrees. Saturation and Value 
are percentages.

RGB (Red, Green, Blue) Enter values in the range 0-255
You can create the same range of colors using either HSV or RGB - use the one you are familiar with.



The basics
To create a 3D heading you just enter the text and the font for the heading (use the T button), then adjust the bevel
and extrude if you wish (using the B and E buttons). Finally drag the text and resize the image window so that 
you’ve got it to be the right size and angle. Then just select the Export menu option to save the image as a GIF or 
JPEG.
Each of these steps is described in more detail on the following pages, along with instructions for more advanced 
features such as setting the background image or color, producing animated GIFs and AVI movies etc.

Positioning, rotating and sizing
Saving a 3D image

Previewing GIF and JPEG files
Creating a movie or animated GIF

Tips for reducing the size of animated GIF files
Altering the font
Altering the text
Altering the 3D extrude
Altering the text color or texture
Altering the bevel
Altering the lights
Altering the background
The Color Picker
Previewing AVI movies



Tips for reducing the size of Animated GIF files
Images of any type that are larger than, say, 50K are not really welcomed by Web users.
Make the image as small as possible by selecting the Crop option on export.
Select 'Front face only' and have no more than about 20 frames per revolution.
When exporting try selecting 16 colors (4-bit) with no dithering and optimized palette. When images are 

animating, the banding is far less obvious than with a static image.
When exporting GIFs (animated or static) that have a complex background, try exporting them as 

transparent GIFs. 



Uninstalling Xara3D
To keep the download size small Xara3D doesn't include an uninstall option. However uninstalling is simple:

1. delete the folder containing Xara3D
2. right-click on the Start menu on the Taskbar, and select Open
3. double-click on Programs. This displays the contents of the top level menu with Xara3D shown at the 

bottom
4. delete the Xara3D shortcut



What's new in Version 2
The main features added in this release are:
Text handling:

Multi-line text, with left center or right alignment options
More characters allowed (up to 80)
New Text Toolbar gives you direct access to many new text options (e.g. tracking and kerning, point size)
You can specify an exact point size for text
On-screen text editing, even while animating

Bitmap textures:
You can apply any bitmap texture to the face and sides of text
Includes samples of bitmap textures
Animations can now rotate around the horizontal or vertical axis
Greater control over animation speed

Other features:
Multi-level undo and redo
File previews in .X3D load and save dialog boxes
File previews in texture import dialog box
MMX compatible so even faster on MMX compatible processors
On-screen display of rotation angle and image size
You can specify exact pixel sizes of bitmap output (allows much smaller and larger bitmaps than before)
Faster rendering and display speeds
Remembers window size and dialog box positions
Export in PNG format, with full alpha-channel anti-aliasing
Drag and drop of X3D and texture files
Changes to keyboard shortcuts so that you can use standard keys to navigate around dialog boxes
Greater control over rotation angle using cursor keys
Unicode support for languages such as Japanese




